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OBJECTIVES

A broad array of common problems from financial world can be
solved through certain logic that we generally call Financial
Engineering. Financial engineers must be able to use specialised
software for solving such kind of problems.

In this lecture, we give a survey of the course MT1460 — Financial
and Risk Management Software (5 points, 60 hours, D level).

This course is given in the framework of the Master Programmes
Analytical Finance (160—200 points) and MIMA Analytical Finance
(60 points).
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A

@ To give a review of existing financial and risk management
software.
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A

@ To give a review of existing financial and risk management
software.

@ To refresh students’ knowledge about typical problems of
financial engineering and their mathematical solutions.
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A

@ To give a review of existing financial and risk management
software.

@ To refresh students’ knowledge about typical problems of
financial engineering and their mathematical solutions.

® To teach students how to solve these problems, using FRONT
ARENA software.
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LECTURES, 3 POINTS

Each lecture (4 hours), except the introductory one, starts with the
presentation of solutions to exercises by some group of students.
After the presentation all students take part in the discussion.
Each student must be able to explain and discuss topics related to
the presentation.

The presentation of solutions to exercises and the following
discussion takes about one hour. During the next two hours the
teacher will follow up the work of groups. During the last hour the
teacher will present the outline of the material of the next lecture.
To pass the lectures, the student must solve all exercises.
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SEMINAR, 2 POINTS

In seminars (4 hours each), the students are expected to apply
FRONT ARENA to solving real-world financial problems that are
not included to the course material.

Every group will obtain a certain part of FRONT ARENA
documentation, where a typical financial problem and methods of
its solutions are described. The group’s report must contain a title
page, abstract, contents, introduction, where the problems are
formulated, solutions, conclusions, and references.
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FINANCIAL AND RISK MANAGEMENT SOFTWARE: COURSE PLAN
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CONTENTS OF LECTURE 5 — “THE LIBOR MARKET MODEL"

= The LIBOR market model: theory.
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CONTENTS OF LECTURE 5 — “THE LIBOR MARKET MODEL"

= The LIBOR market model: theory.
=z Context mapping.
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CONTENTS OF LECTURE 5 — “THE LIBOR MARKET MODEL"

= The LIBOR market model: theory.
=z Context mapping.
1 Valuation of caps and floors.
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CONTENTS OF LECTURE 5 — “THE LIBOR MARKET MODEL"

= The LIBOR market model: theory.
=z Context mapping.

1 Valuation of caps and floors.

1 Exercises.
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= Definition of forward rates.

1= The mathematical description of the LIBOR market model.
1 Cap volatility calibration.
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THE THEORETICAL PART

= Definition of forward rates.
= The mathematical description of the LIBOR market model.
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THE THEORETICAL PART

= Definition of forward rates.
= The mathematical description of the LIBOR market model.
=z Cap volatility calibration.
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DiscouNT BONDS

A contract, which gives the holder an amount 1 at some future date
T, is referred to as discount bond. 1 is called the notional or
face value and T is referred to as the maturity date. The price at
time t of a discount bond with maturity T and face value 1 is
denoted by P(t, T).
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FORWARD RATES

The simply compounded forward rate at time t spanning the
future period [Ty, T2l, F(t, T1, T») is defined by

P(t, Tp) 1
P(t, Ty) 1+ F(t, Ty, To)(Ta - Tq)

The following diagram illustrates a set of forward rates spanning
the set of dates {Tj}:

7 7 oy
Today /) =% " i
I i i i i i i i |
s s T A
-

Discount Bond as Mumeraire
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TaE LIBOR MARKET MODEL: NOTATION

Let the tenor structure be 0 = Ty < T1 < --- < T and i an integer
ranging over the resets of the rates, e.g. 1 <i<n.

We define n(t) to be the unique index such that T, is the next
tenor date after t.
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TaE LIBOR MARKET MODEL; THE DRIFT TERMS

The drift terms p; depend on the choice of numeraire and can be
determined by applying the assumption of no arbitrage. Suppose
we have forward rates as the underlying rates and choose
P(To, Tir1) as the numeraire. Then the drift terms become

o Tifi(t)ok(t)
wi(t) = oi(t) —
k;:lt) 1+ Tifi(H)
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THe LIBOR MARKET MODEL: EQUATIONS

The m-factor model is given by the following stochastic differential
equation (SDE) for the underlying rates (swap or forward):

df; .
— = wi(fi(D, Dy dt + > oix(0) dze(1).
fi k=1

The solution of the SDE is

;
fi(t) = £i(0) exp ( fo (ul(s) =50 (S))

m AT
> f 0ik(8) dzk(s)).
k=10
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CAP VOLATILITY EQUATIONS

Assume that each underlying rate fi(t) has a lognormal distribution
with variance equal to 03t, where o5 is the implied Black volatility,
which can be read from the market. Then the instantaneous
volatility at reset for each rate is related to the above expression in
the following way:

T
f o?(t) dt = 05T, (1)
0
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CAP VOLATILITY CALIBRATION

There are infinitely many solutions to equations (1), and our goal is
to pick one that fits our needs. Let o(t) = (a + bt)e ! + d and
oi(t) = kio(T; — t). The calibration proceeds as follows.

@ Find values on the constants a, b, ¢, and d such that equation
(1) fit as close as possible.
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CAP VOLATILITY CALIBRATION

There are infinitely many solutions to equations (1), and our goal is
to pick one that fits our needs. Let o(t) = (a + bt)e ! + d and
oi(t) = kio(T; — t). The calibration proceeds as follows.
@ Find values on the constants a, b, ¢, and d such that equation
(1) fit as close as possible.

@ Set values of the k; as

0'257',-

f io?(t) dt
0
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= The list of necessary mappings.

= Example: mappings for a swaption.

1= Valuation parameters.
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CONTEXT MAPPING

1= The list of necessary mappings.
1 Example: mappings for a swaption.
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CONTEXT MAPPING

1= The list of necessary mappings.
1 Example: mappings for a swaption.
= Valuation parameters.
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THE LIST OF NECESSARY MAPPINGS

In order to use the LIBOR Market Model when valuing instruments
the following context mappings must be performed:

@ Map the instrument to the Core Valuation Function > LIBOR
Market Model. This mapping tells FRONT ARENA to value
the instrument with the LIBOR Market Model.
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THE LIST OF NECESSARY MAPPINGS

In order to use the LIBOR Market Model when valuing instruments
the following context mappings must be performed:

@ Map the instrument to the Core Valuation Function > LIBOR
Market Model. This mapping tells FRONT ARENA to value
the instrument with the LIBOR Market Model.

@ Map the instrument to an appropriate correlation matrix. The
LIBOR Market Model requires a correlation matrix as input,
and this mapping makes sure it gets one.
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THE LIST OF NECESSARY MAPPINGS

In order to use the LIBOR Market Model when valuing instruments
the following context mappings must be performed:

@ Map the instrument to the Core Valuation Function > LIBOR
Market Model. This mapping tells FRONT ARENA to value
the instrument with the LIBOR Market Model.

@ Map the instrument to an appropriate correlation matrix. The
LIBOR Market Model requires a correlation matrix as input,
and this mapping makes sure it gets one.

® Map the instrument to an appropriate volatility Landscape. If
the instrument is a Cap/Floor it suffices to map a volatility
Landscape to the rate index.
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THE LIST OF NECESSARY MAPPINGS

In order to use the LIBOR Market Model when valuing instruments
the following context mappings must be performed:

@ Map the instrument to the Core Valuation Function > LIBOR
Market Model. This mapping tells FRONT ARENA to value
the instrument with the LIBOR Market Model.

@ Map the instrument to an appropriate correlation matrix. The
LIBOR Market Model requires a correlation matrix as input,
and this mapping makes sure it gets one.

® Map the instrument to an appropriate volatility Landscape. If
the instrument is a Cap/Floor it suffices to map a volatility
Landscape to the rate index.

@ If the instrument is a Swaption, we must, in addition, map a

volatility Landscape to the instrument itself.
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MAPPING FOR A SWAPTION

Consider the following swaption and underlying swap:
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THE MAPPINGS THAT APPLY

The mappings that apply are in the Special > Information window:

]

[
Instrunent: EUR/01/TRS.3u/2Y/Payer is using paranster(s)

Mapped Yield Curve: EUR-SWAP for forward rate estimation (mapped to instrument EURIBOR-6H (EUR))
- Mapped in Context Global

~ Used Yield Curve: EUR-SW&F

Mapped Yield Curve EUR-SWAP for discounting (mapped to currency EUR for EUR/IRS/2Y)

~ Happed in Contest Global

~ Used Yield Curve EUR-SWAF

Mapped Yield Curve: EUR-SWAP for discounting (mapped to currency EUR for EUR/01/IRS-3n/2¥ Payer)
~ Mapped in Context Global

- Used Yield Curve: EUR-SWAP

Mapped Volatility EUR-Swaption-Snile (napped to ValGroup of underlying of EUR/01/IRS/3n/2¥-Payer (EUR})
~ Mapped in Context Global

~ Franswork Black & Scholes

Used narkst price 0.0000

Used volatility 289350

Used discount rate 2.1022

Underlying: EUR/IRS/2Y
Underlying forvard (Curve): 2.8141
Used Core Valuation Function: Black-Scholes

Used Risk Factor Groups

— Volatility: EUR_Vola (EUR-Svaption-Smile)
- FX EUR_FX (ELR)
— Intersst Rate EUR_Swap (EUR-SVAE)

Ly o

Frint Close

4

\ v 4
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THE FIRST MAPPING

First, open an appropriate context in File > Open of the Context
application. In this example it is 'Global’. To add a context link
select Edit > Add ContextLink as follows:

Add Context Link i = |

— Context Link Add

tdap Twp=: | Cors Waluation Function Uipdate

Eemove

Earrier Snalbic =

Easket &s Single Underluing Close
Binomial

Ejerksund-Stensland

Elack-Scholes
Black-5choles rield
Compound

Finite Difference

Forwmard Start Elack-Scholes
Gentle-w orst

Hazard Flate Fodel

LIE = A o

FASTOErIE Bl atataee

tonte Carlo B asket Underling =]
Fap to: [1nstrument -1
Ins Tepe:  [Oprion =1
Instrument: [EURA01 SRS A3md 2 AP aver |
| Time Starmps... |
=
\ ¥V 4
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THE CORRELATION MATRIX

The theoretical part Context mapping Valuation of caps and f

Correlations matrices are set up using the Correlation application,
which is accessed by selecting Data > Correlation from the

PRIME. The correlation matrix used by “EUR/01/IRS/3m/2Y/Payer"
is illustrated in the figure below:

Ha Correlation

Eil= Misws Special Help
O === |
Mame: [Euribor-Em
Audd Element
Tevpe Mone = Element I vl S dd I
Sub Tupe Fone e Bucket: IEICI Bermowve I
— Mumber — Tyope T=) Bucket
Fow I I I I
Colurmr: I I I
[ Correlation b4 atriz
ol Tupe: I "I
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THE SECOND MAPPING

The theoretical part Context mapping Valuation of caps and f

To add this context link select Edit > Add ContextLink as the
following figure shows:

| Add ContextLinke
— Conkext Link

Sadd
FMap Type: ICDrreIatiDn kA atkri= vI

Update
E uribor-6m

Eemove
Easket
CDSEasket Llose
DrifferentialsS wap
EQB aszket Correlation
EUR-LIBOR-Ek
E uribior
E uribor-Sm

IndexCorr

iTrams
CluantoCorrelations
R ainbowvecaorr
LIS-Basket

kM ap ta: Ilnstrument

Ins Type: I O ption

Instrument: [EUR A0 MRS A 3msd 2y AP aper

L4l

| Time Stamp=... I

Dmitrii Silvestrov, Anatoliy Malyarenko Financial Engineering with FRONT ARENA



Introduction The course A typical lecture Concluding remar

THE THIRD MAPPING

The theoretical part Context mapping Valuation of caps and f

To enable the calibration process to take place it is necessary to
map a volatility Landscape to the underlying rate index used by
“EUR/01/IRS/3m/2Y/Payer", in our case “Euribor-6m". The
mapping procedure is performed in the same way as for the
correlation matrix mapping and the result is pictured in the

following figure:

B Context - Global N

File Edit Yew Tools Special Help

=10l

SH|&|
Context: |Global
- Context Link:
[Ins‘rumem IGmup lCurr [Anm |At|v 2 |Attr 3 !Mappmg Type [Parame\er Name !Faramaier Type a|
[ L CapiFlaor ELR “al Group EUR-CAPFLOOR Voltilty
ELIRIBOR-3M ELR Instrumert ELR-CAPFLOOR oltilty
ELR-LIBOR-Gh ELR Instrument EUR-CARFLOOR Voltilty
BoncFutre EUR al Group EUR-FuturOption alatiity
[ | Quartoswvan EUR al Group. EUR-Hullhte alatiity
U EURIEOR-6M EUR Instrument EUR-Svraption oty
Swap ELR “al Group EUR-Svraption-Smile olatilty
H Lhat ELR “Val Group EUR-Svvaption-Smile “Voltilty
STCKHED ELR Instrument EuroSTOKXED oltilty -
ELR UsD Instrument FXELRLIED oltilty
=3 ELR Instrument Flat val Voltilty |
4] | »
\ Y 4
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THE FOURTH MAPPING

Once more, to enable the calibration to take place it is also
necessary to map “EUR/01/IRS/3m/2Y/Payer" to an appropriate
volatility Landscape. In this example the volatility Landscape
'EUR-Swaption’ is chosen as illustrated in the following figure:

-Iolx
Fie Edi View Tools Special Help
BH|S
Context IE\oba\—
~Context Link:
‘Ins‘trumem IGmup Icurr !AnM |Arl12 |Attr3 !Mapping Type Parameter Name Parameter Type &
LhiM-CapeFloor EUR “al Group EUR-CAPFLOOR “olatility
EURIBOR-3M EUR Instrument EUR-CAPFLOOR “olatiity
EUR-LIBOR-EM EUR Instrument EUR-CAPFLOOR “olatiity
BoncF uture EUR “al Group EUR-FutureOption “olatility
QuartoSywap EUR “al Group EUR-Hulfhite “olatility
U EURIBCR-EM EUR Instrumert EUR-Syvaption “olatility
A EURIDH RS 3m/2Y Payer EUR Instrument EUR-Svvaption “olatility
Swap EUR al Group EUR-Svvaption-Smile olatiity
LA EUR al Group EUR-Svvaption-Smile olatiity -
STOXXS0 EUR Instrument EuroSTOXXS0 olatiity
EUR usD Instrument FYEURLED Volatiity -|
q | I
\ v 4
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VALUATION PARAMETERS

The theoretical part

Before running the LIBOR Market Model in FRONT ARENA, it is
necessary to specify the number of Monte Carlo simulations and

the number of factors to be used by the model. This is done in
Admin > Administration Console application.

B Ad tration Console

R (= |

(1 Accounting Parameters
£ [ Choice List

{3 Credit Limit Parameters

{3 Page Definition

Waluation Parameters

&2 DEFAULT (Mapped]
o MTH

Users, Groups & Organisations

User Profile

Parameter Override

RiskFactor Grouping

Control Parameters

Portfolios

mll_ﬂ
preepe -0

B

Context mapping Valuation of caps and f

General | Profit & Loss | Default Price Finding | Greeks & Buckets  Madel Settings | IR4 Hedge | Mise. |

- Optian Pricing

- LIBOR Market Model

I™ | Binomial B&S Smoothitg

I~ | Binomial Fichardson Extrapolation

Binomial Dividend Adiust [Home 7

[~ Fiepo as Risk Free Rate Simulations: [6382
Trinomial Steps: [5 Factors: 3
Binomial Steps: E Random Generator: none
Binormisl Process: [Forwam =1 || Jump Type: none
Binomisl Tree Modsl [Defavit | || Price Strategy: none

I~ Use Antithetic 5ampling

T

Simulations:

- Finite Difference

Random Generator:

’— Easket CDS Model

none

REEEES S0 - Convesity Adiustment
State Steps: Edl % InAuear

¥ Finite Diff for Multiple Options ¥ CMS

[~ Solve for Wolatility in Multiple O ptions I~ IRF
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i Plain vanilla caps and floors.
i Ratchet caps.

1z Sticky caps.
= Momentum caps.
1= Flexi caps.

1= Chooser caps.
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TYPES OF CAPS AND FLOORS

i Plain vanilla caps and floors.
1= Ratchet caps.
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TYPES OF CAPS AND FLOORS

i Plain vanilla caps and floors.
1= Ratchet caps.
1= Sticky caps.
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TYPES OF CAPS AND FLOORS

i Plain vanilla caps and floors.
1= Ratchet caps.
Sticky caps.

5 B

Momentum caps.
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TYPES OF CAPS AND FLOORS

i Plain vanilla caps and floors.
1= Ratchet caps.

1= Sticky caps.

= Momentum caps.

= Flexi caps.
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TYPES OF CAPS AND FLOORS

i Plain vanilla caps and floors.
1= Ratchet caps.

Sticky caps.

Momentum caps.

Flexi caps.

Chooser caps.
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VALUATION OF CAPS AND FLOORS

For each type of cap and floor we provide the following information.
= The exact definition.
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VALUATION OF CAPS AND FLOORS

For each type of cap and floor we provide the following information.
= The exact definition.

= The description of additional fields required by a certain type
of a cap or a floor.
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A TYPICAL EXERCISE

Calculate the theoretical price of the ratchet floor with the following
parameters, using the LIBOR market model.

Dmitrii Sil , A liy Maly Financial Engineering with FRONT ARENA
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The theoretical part Context mapping Valuation of caps and f
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REMARKS AND SUGGESTIONS TO FRONT ARENA

Simultaneously with preparing a course, we write a separate
document containing our remarks and suggestions. It is supposed
to contain three sections:

® realisation of methods of valuation different financial
instruments;

Dmitrii Silvestrov, Anatoliy Malyarenko Financial Engineering with FRONT ARENA
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REMARKS AND SUGGESTIONS TO FRONT ARENA

Simultaneously with preparing a course, we write a separate
document containing our remarks and suggestions. It is supposed
to contain three sections:

® realisation of methods of valuation different financial
instruments;

® FRONT ARENA documentation;
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REMARKS AND SUGGESTIONS TO FRONT ARENA

Simultaneously with preparing a course, we write a separate
document containing our remarks and suggestions. It is supposed
to contain three sections:

® realisation of methods of valuation different financial
instruments;

® FRONT ARENA documentation;
® the contents of the simulator’s database.
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