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The LIBOR market model

An interest rate derivative is a contract whose
value depends on an underlying interest rate. The
valuation of such a derivative may be dependent on
the value of the underlying rate at several different
future dates. Whilst models such as the Black
model assume log-normality for a single forward
rate or swap rate when pricing such derivatives as,
caplets and swaptions respectively, many interest
rate derivatives have future payoffs dependent on
several underlying rates.

The LIBOR Market model also referred to, as
the “BGM/J model” is a multi-factor term structure
model that allows for future volatility patterns to
be considered. The LIBOR Market framework
uses LIBOR rates for modeling, which are market
observable and has therefore become very popular
among traders. Existing interest rate models are
limited by the fact that, first, they model non-market
observable quantities and, secondly, often use one
factor.
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Black model

The standard model for valuing interest rate
options, caps/floors and European swaptions, is the
Black model. The Black model is used by traders in
the market to price these derivatives and as will be
seen later on, the analytical Black formulas will play
a key role when calibrating the LIBOR Market model.

Before attempting to calculate values (prices) for
these interest rate derivatives it is necessary to make
certain assumptions about the underlying rates.

The basic assumptions under the Black model
are:

+ the underlying forward rate or swap rate is a log
normally distributed random variable;

+ the volatility of the underlying is constant;

+ prices are arbitrage free;

+ there is continuous trading in all instruments.
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Forward rates

Before defining the underlying variables, the
rates, it is important to introduce the concept of
discount bonds. Discount bonds are traded in the
market but more commonly are so called coupon-
bearing bonds. These have several guaranteed
future cash flows instead of just one. The coupon-
bearing bonds can be reduced to a set of ordinary
discount bonds. In fact, to get the price of a discount
bond one often imputes this price from (suitable)
coupon-bearing bonds.

A contract, which gives the holder an amount 1
at some future date T , is referred to as discount
bond. 1 is called the notional or face value and T
is referred to as the maturity date. The price at time
t of a discount bond with maturity T and face value 1
is denoted by P(t,T ).

To deal with this assumption of a continuum
of prices (also known as the discount function),
in practice one selects a set of discount bond
prices (the benchmark instruments) and then simply
interpolates between them. For theoretical purposes
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it is (almost) always assumed that there is a discount
bond available for every maturity date T .

The simply compounded forward rate at time
t spanning the future period [T1,T2], F(t,T1,T2) is
defined by

P(t,T2)
P(t,T1)

=
1

1 + F(t,T1,T2)(T2 − T1)
.

The following diagram illustrates a set of forward
rates spanning the set of dates {Ti}:

These simply compounded forward rates also
define the LIBOR rates (London Inter Bank Offer
Rates). There are equivalents to LIBOR in other
countries for example the Swedish version referred
to as STIBOR (Stockholm Inter Bank Offer Rate).

Because the LIBOR rates are expressed in
terms of discount bonds it is easy to see that
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these could be an alternative to the discount
bonds when building the discount function in certain
circumstances. More explicitly, where one was
receiving money at a discrete set of known future
dates T1, . . . , Tn, and wanted to calculate todays
value of these future cash flows, then it would be
sufficient to know the value of the discount function
at these dates given by a discrete set of LIBOR rates.
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Caps and floors

A caplet connected with the forward rate
F(Ti,Ti,Ti + τi) and with strike k, is a contract, which
at time Ti + τi gives the holder the cash flow:

τi max{F(Ti,Ti,Ti + τi) − k, 0}.

A cap is a set of caplets. The price of a caplet using
the Black model is given by:

Vi(0) = P(0,Ti+1)Niτi(Fi(0)Φ(a1i) − kΦ(a2i)),

where

k the strike of an interest rate cap
Vi value of ith caplet
τi time to maturity of the ith caplet
Ti reset dates of forward rate
P discount factor
Ni notional principal of each caplet
F forward rate
τi tenor or Ti+1 − Ti.
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a1i and a2i are given by

a1i =
ln(Fi(0)/k) + σ2

i Ti/2

σi
√

Ti
,

a2i = a1i − σi

√
Ti,

and σi denotes the volatility for the ith caplet.

A floorlet connected with the forward rate
F(Ti,Ti,Ti + τi) and with strike k, is a contract, which
at time Ti + τi gives the holder the cash flow:

τi max{k − F(Ti,Ti,Ti + τi), 0}.

A floor is a set of floorlets. The price of a floorlet
using the Black model is given by:

Vi(0) = P(0,Ti+1)Niτi(kΦ(−a2i) − Fi(0)Φ(−a1i)),
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LIBOR Market Model

Let the tenor structure be 0 = T0 < T1 < · · · < Tn

and i an integer ranging over the resets of the rates,
e.g. 1 ≤ i ≤ n.

We define η(t) to be the unique index such that
Tη(t) is the next tenor date after t.

The (one factor) model is given by the
following stochastic differential equation (SDE) for
the underlying rates (swap or forward):

d fi
fi
= µi( fi(t), t) dt + σi(t) dz(t),

where

fi forward/swap rate at time i
µi drift term
σi volatility of rate i
z(t) Wiener process.

The solution to this SDE is:

fi(t) = fi(0) exp
(∫ T

0

(
µi(s) −

1
2
σ

2
i (s)

)
ds +

∫ T

0
σi(s) dz(s)

)
.
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The drift terms µi depend on the choice of numeraire
and can be determined by applying the assumption
of no arbitrage. Suppose we have forward rates as
the underlying rates and choose P(T0,Ti+1) as the
numeraire. Then the drift terms become

µi(t) = σi(t)
i∑

k=η(t)

τi fi(t)σk(t)
1 + τi fi(t)

.

A one-factor model means that all the rates are
perfectly instantaneously correlated. In this case,
a single Wiener process is sufficient to evolve the
rates. This is not often a reasonable assumption,
and eliminates one of the advantages of employing
the LIBOR Market model. A m-factor model is one
where m independent Wiener processes are used to
evolve the rates. In this case the equation becomes

d fi
fi
= µi( fi(t), t) dt +

m∑
k=1

σi,k(t) dzk(t).

where σi,k(t) is the component of the volatility of fi(t)
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attributable to the kth factor. They must satisfy

m∑
k=1

σ
2
i,k(t) = σ

2
i (t).

The solution of the SDE is

fi(t) = fi(0) exp
(∫ T

0

(
µi(s) −

1
2
σ

2
i (s)

)
ds

+

m∑
k=1

∫ T

0
σi,k(s) dzk(s)

 .
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Cap volatility calibration

Assume that each underlying rate fi(t) has a
lognormal distribution with variance equal to σ2

Bt,
where σ2

B is the implied Black volatility, which can
be read from the market. Then the instantaneous
volatility at reset for each rate is related to the above
expression in the following way:

∫ Ti

0
σ

2
i (t) dt = σ2

BTi. (1)

There are (infinitely) many solutions to these
equations, and our goal is to pick one that fits our
needs. Let

σ(t) = (a + bt)e−ct + d

and
σi(t) = kiσ(Ti − t).

The calibration proceeds as follows.

À Find values on the constants a, b, c, and d such
that equation (1) fit as close as possible.
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Á Set values of the ki as

ki =

√√√√√√√ σ2
BTi∫ Ti

0
σ

2
i (t) dt

.

The second step ensures equality for the
equations in (1), that is, the instantaneous volatility
and the implied Black volatility is equal at each reset.
This completes the volatility calibration for caps.
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Context mapping

In order to use the LIBOR Market Model when
valuing instruments the following context mappings
must be performed:

À Map the instrument to the Core Valuation
Function > LIBOR Market Model. This mapping
tells FRONT ARENA to value the instrument with
the LIBOR Market Model.

Á Map the instrument to an appropriate correlation
matrix. The LIBOR Market Model requires a
correlation matrix as input, and this mapping
makes sure it gets one.

Â Map the instrument to an appropriate volatility
Landscape. If the instrument is a Cap/Floor
it suffices to map a volatility Landscape to the
rate index. If the instrument is a Swaption, we
must, in addition, map a volatility Landscape to
the instrument itself. The LIBOR Market Model
then uses these volatilities (or this volatility if the
instrument is a Cap/Floor) in its calibration step.
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These mappings are specific for the LIBOR
Market Model. There are also some general
valuation mappings that must be done.

To illustrate this mapping process lets consider
the following Swaption:

It has the following underlying swap:
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In the Special > Information window of the
Swaption we can see the mappings that apply. They
are as follows:
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In order to value the Swaption with the LIBOR
Market Model, it must first be mapped to the Core
Valuation Function LIBOR Market Model in the
Context application.

First, open an appropriate context in File >
Open. In this example it is ’Global’. To add a context
link select Edit > Add ContextLink as follows:
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Once the ContextLink has been added it will
appear in the Context application window as
displayed in the following figure:
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In the above illustration it can be seen that the
“EUR/01/IRS/3m/2Y/Payer” instrument is associated
with the “LIBOR Market Model” Core Valuation
Function. Therefore, this Core Valuation Function
will be used in the valuation.

An integral part of the LIBOR Market valuation
process is setting the correlations between the rates,
which are user defined. Correlations matrices are
set up using the Correlation application, which
is accessed by selecting Data > Correlation
from the PRIME. The correlation matrix used by
“EUR/01/IRS/3m/2Y/Payer” is illustrated in the figure
below:
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To add this context link select Edit > Add
ContextLink as the following figure shows:
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Once the ContextLink has been added it will
appear in the Context application window as
displayed in the following figure:
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To enable the calibration process to take place
it is necessary to map a volatility Landscape to the
underlying rate index used by “EUR/01/IRS/3m/2Y/Payer”,
in our case “Euribor-6m”. The mapping procedure
is performed in the same way as for the correlation
matrix mapping and the result is pictured in the
following figure:

Once more, to enable the calibration to take
place it is also necessary to map “EUR/01/IRS/3m/2Y/Payer”
to an appropriate volatility Landscape. In this
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example the volatility Landscape ’EUR-Swaption’ is
chosen as illustrated in the following figure:

There is one difference between how you map
a Swaption and a Cap/Floor. For a Cap/Floor
it is sufficient (and necessary) to map a volatility
Landscape to the rate index.

A Swaption needs in addition, one volatility
Landscape mapped to the instrument itself. The
other mappings are necessary for both Swaptions
and Caps/Floors.
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Valuation parameters

Before running the LIBOR Market Model in
FRONT ARENA, it is necessary to specify the
number of Monte Carlo simulations and the number
of factors to be used by the model. This is done in
Admin > Administration Console application.

In the illustration below the number of simulations
used is 16, 382 and the number of factors is 3:
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Caps and floors

It is assumed that all the necessary settings, as
discussed before, have been taken care of. The
different Caps/Floors that can be valued in FRONT
ARENA using the LIBOR Market Model are plain
vanilla, “Ratchet”, “Sticky”, “Momentum”, “Flexi”, and
“Chooser”.

All are described there, with the exception of a
plain vanilla. Assuming that the correct settings have
been done, entering a plain vanilla Cap/Floor and
value it with the LIBOR Market Model is no different
had it been valued with Black’s Model.

From hereon we only discuss Caps. Definitions
of the Floors can easily be derived from the
corresponding Cap definitions.
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Notation

T1 < T1 < · · · < Tn the reset dates of the cap
Ki the strike at the ith reset
Li the LIBOR with reset at Ti.

The following table maps the different fields in the
Cap definition in FRONT ARENA to a variable name
that is more appropriate to use in the mathematical
formulas.

Field Variable
Spread X
Limit m
Strike K
Barrier b
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Ratchet cap

A Ratchet Cap is like a plain vanilla Cap except
that the strike is given by:

Ki =

min{K,m}, i = 1
min{Ki−1 + X,m}, i > 1.

Ratchet Caps incorporate rules for determining
how the cap rate for each caplet is set. The cap rate
equals the LIBOR rate at the previous reset date plus
a spread. A limit is then set on the strike level, above
which a strike cannot be set.

Entering a Ratchet Cap involves setting three
additional fields in the Cap definition compared to
entering a plain vanilla Cap. To start with, we have
to set Exotic Type > Ratchet. This makes the
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fields Spread and Limit appear in the Cap definition.
Finally, we need to set Spread and Limit.

Note that the Strike field in the Cap definition has
a different meaning in a Ratchet Cap than in a plain
vanilla Cap. In a Ratchet Cap it decides the initial
value on the strike.
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Sticky cap

A Sticky Cap is like a plain vanilla Cap except that
the strike is given by:

Ki =

min{K,m}, i = 1
min{min{Ki−1, Li−1} + X,m}, i > 1.

In a Sticky Cap, the cap rate equals the previous
capped rate plus a spread. A limit is then set on the
strike level, above which a strike cannot be set.

Entering a Sticky Cap involves setting three
additional fields in the Cap definition compared to
entering a plain vanilla Cap. To start with, it is
necessary to set Exotic Type > Sticky. This makes
the fields Spread and Limit appear in the Cap
definition. Finally, we need to set Spread and Limit.

Note that the Strike field in the Cap definition has
a different meaning in a ’Sticky’ Cap than in a plain
vanilla Cap. In a ’Sticky’ Cap it decides the initial
value on the strike.
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Momentum cap

A Momentum Cap is like a plain vanilla Cap
except that the strike is given by:

Ki =


min{K,m}, i = 1
min{Ki−1 + X,m}, i > 1, Li − b > Li−1

min{Ki−1,m}, i > 1, Li − b ≤ Li−1.

Entering a Momentum Cap involves setting four
additional fields in the Cap definition compared to
entering a plain vanilla Cap. To start with, we have
to set Exotic Type > Momentum. This makes the
fields Barrier, Spread and Limit appear in the Cap
definition. Finally, we need to set Barrier, Spread
and Limit.

Note that the Strike field in the Cap definition has
a different meaning in a Momentum Cap than in a
plain vanilla Cap. In a Momentum Cap it decides the
initial value on the strike.
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Flexi cap

Let a be a positive integer less than or equal to
the number of resets, i.e. 0 < a ≤ n. A Flexi Cap
is like an ordinary Cap except that only the a first
in-the-money Caplets are exercised.

Entering a Flexi Cap involves setting two
additional fields in the Cap definition compared to
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entering a plain vanilla Cap. To start with, we
have to set Exotic Type > Flexi. This makes the
field Exercises appear in the Cap definition, which
corresponds to the integer a seen above. Finally, we
need to set this field.
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Chooser cap

Let a be a positive integer less than or equal to
the number of resets, i.e. 0 < a ≤ n. A chooser
Cap is like a Flexi Cap except that the contract holder
can choose which a Caplets to exercise. Once the
reset of a Caplet has taken place, it can no longer
be chosen.

This is how the LIBOR Market Model in FRONT
ARENA values a chooser Cap. Of course, it includes
all the chosen Caplets. Suppose that c Caplets have
been chosen, and that c < a ≤ n. This means that
there are still a − c Caplets that can be chosen. In
this case it picks a − c, or as many as possible but
no more than a − c, of the remaining Caplets with
highest present value. In other words, it employs an
optimal strategy for the remaining of the Cap.

Initially, entering a chooser Cap involves setting
two additional fields in the Cap definition compared
to entering a plain vanilla Cap. To start with, we have
to set Exotic Type > Chooser. This makes the
field Exercises appear in the Cap definition, which
corresponds to the integer a seen above. Finally, we
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need to set this field.

During the life of the chooser Cap we must
choose which of the a Caplets to exercise. We
choose a Caplet by entering a non-zero value in the
record fixed time of the database table CashFlow.

Now we have defined the chooser Cap. Let us
take a look at the Tools > Cash Flow Table when
we have not chosen any Caplet to exercise.
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What is interesting is the PV column. We see
that the second Caplet is worth 0 although it has a
Pay Day in the future. This is because we have not
chosen to exercise this Caplet. We will return to this
example in the lecture about ARENA SQL.

– Typeset by FoilTEX – 36



MT1460 2005, period 3

Example: Bermudan call swaption

Bermudan Swaptions are defined in the Option
application by selecting the Type > Bermudan. The
exercise dates are entered in the Exercise Events
dialog accessed by clicking the Exercises. . . button.
This is illustrated in the following figure:
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Before proceeding, the underlying instrument
must be selected. In this example the instrument
EUR/IRS/020827-070827/5.5 has been chosen.
The next step is to enter the relevant exercise dates
and strike rates. Click the Exercises. . . button to
display the Exercise Events window:

The underlying swap has the following details:
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Exercises

À Calculate the theoretical price of the ratchet floor
with the following parameters

using the LIBOR market model.

Á Calculate the theoretical price of the sticky cap
with the following parameters
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using the LIBOR market model.

Â Calculate the theoretical price of the flexi cap with
the following parameters
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using the LIBOR market model.

Ã The underlying swap has the following details:
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The corresponding Bermudan swaption has the
following parameters
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and the following exercise dates:
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Calculate the theoretical price of the swaption,
using the LIBOR market model.
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