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Abstract
Contents of the lecture.

☞ FRONT ARENA architecture.
☞ The PRIME Session Manager.
☞ Instruments.
☞ Valuation: background.
☞ Valuation in PRIME.

FRONT ARENA system architecture
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FRONT ARENA is a software to support sales, trading and risk management in front,
middle and back offices.

Client/server architecture
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FRONT ARENA is based on client/server architecture .

Servers take care of central tasks such as external connections, data storage and
external logging.

Clients contain the end-user interfaces and sufficient business logic to reduce the
processing load on the servers. This distributed processing allows reports, calculations and
data simulations to be handled locally. Data is received from the servers in real time and
cached where appropriate.

Application components, system components
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Another distinction is between application components and system components .
The application components are the FRONT ARENA clients. The system components are the
various FRONT ARENA servers together with other components used to achieve integration
within FRONT ARENA and with third party systems.

FRONT ARENA clients: PRIME and OMNI

PRIME is the main client in FRONT ARENA. It is used for trading, position keeping and
risk management.

OMNI is an alternative client for exchange-based equities trading.

ARENA Data Server (ADS)
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The ARENA Data Server (ADS) provides database services to the main FRONT
ARENA client(PRIME), including data storage and a transaction log . PRIME subscribes
to ADS for real-time data updates.

ADS, ADM, and the ARENA database
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ADS is a general database service provider. In theory it could connect any relational
database. In practice, it is used to connect to the ARENA database , the main database in
FRONT ARENA.

To work with a database, ADS needs to know about the tables, fields, and relationships
in the database. For the ARENA database, this is defined in the ARENA Data Model (ADM) .
The SQL scripts that defined the ADM are packaged into a separate component, also called
ADM.

The PRIME Session Manager

The PRIME Session Manager is the main control for a PRIME Session connected to the
ARENA database. From here you can manage you workspace:

☞ Open other windows.

☞ Save and retrieve Workspaces.

From the various menus on the PRIME Session Manager you can open other windows.
Each window offers different features and functionality to help you carry out your work.
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File Session administration.

Analysis Pricing, position management, and risk management.

Trading Define instruments and execute trades.

Data Valuation parameters and portfolio definition.

Admin Reporting and static data.

System System management.

Help Help and About.

Workspaces

Normally when a user starts PRIME for the first time, only the Session Manager will be
displayed. Then the user should open various windows that can be used to carry out business
tasks. Creating and saving a Workspace is the method to store a desktop layout that can
easily be retrieved later so the user does not have to manually re-open windows every time
PRIME is started.

The user can save a workspace, that is the position and contents of the opened windows,
by selecting File → Save as and then saving with an appropriate name. You can save as many
workspaces as you like.

If you already have a previously saved workspace and wish to save it with a different
configuration, you can do this by selecting File → Save and the workspace will be defined
with the current settings.

You can open an existing workspace by selecting File → Open from the Session
Manager, selecting the workspace that you want to open, then clicking OK. The current
workspace will be replaced with the one selected.

The default Workspace opens automatically when PRIME is started. Each user can
have an individual default Workspace. To make the current Workspace the default, select File
→ Save As Default from the Session Manager.

Instruments: traditional classification

The convention in financial markets is to divide instruments according to the following
sectors.
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➀ Fixed income instruments: interbank certificate of deposits (CD), deposits, commercial
papers (CP), banker’s acceptances, and Treasury bills.

➁ Equities: various types of stock issued by public companies.

➂ Currencies and commodities.

➃ Derivatives: interest rate, equity, currency, and commodity derivatives.

➄ Credit instruments: high-yield bonds, corporate bonds, credit derivatives, and various
guarantees.

Instruments: classification in FRONT ARENA

For valuation purposes, PRIME divides instruments into two categories, cash flow
instruments and derivative instruments. Examples of each type are as follows:

Cash flow instruments : swaps, currency swaps, caps/floors, deposit/loans bills, bonds,
FRNs, promissory loans, CD’s, rate indices.

Derivative instruments: futures, forwards, options.

Applications for defining new instruments are found in the Trading menu in the Session
Manager. These applications are also used for the retrieval of previously defined instruments
that have been stored in the database. Each instrument type has its own application. The
overall structure of an individual cash flow instrument is defined in the instrument definition
application. Each single cash flow belonging to that instrument can then be edited in terms of
amount, rate, dates, and so on. Cash flows can also be removed or added.

Valuation: background

PRIME estimates the value of instruments using two basic components:

☞ Yield curves.

☞ Volatility structures.

Current market conditions are represented through sets of benchmark instruments used
when deriving the curves and volatility structures. All instruments are mapped to yield curves
and, if applicable, to a volatility structure. The parameters that are derived from these curves
are then used when valuing the instrument.
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Zero coupon pricing

The concept behind zero coupon pricing is the evaluation of all individual cash flows as
if they were zero coupon bonds. The evaluation is made using a yield curve or, alternatively, a
discount function, which accurately describes current market conditions.

The pricing of liquid, standardised instruments is quite simple — the current market price
is used.

The zero coupon pricing methodology becomes important when pricing instruments, for
which no market prices are available. It is also needed for pricing standardised instruments
which do not have reliable market prices. In this case, zero coupon pricing will be used to
price these instruments consistently alongside the liquid instruments. This is a kind of relative
pricing where user preferences only need to be taken account of to a small extent.

The discount function

The discount function describes the present value at time t0 of a unit cash flow at time t:
P(t0, t).

In most cases, t0 is the current date and is sometimes dropped for notational
convenience. The remaining variable t then refers to the time between t0 and t.
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At t = 0, the discount function always has the value 1. The discount function is
monotonically decreasing, which corresponds to stipulation that interest rates are always
positive. It never reaches zero since all cash flows, no matter how far in the future they are
paid, are always worth more than nothing.

The discount function has a mathematical relationship to the spot yield curve, although
the “yield curve” is not a well-defined concept. The relationship between the discount function
P(t) and different yield curves r(t), using a day count convention that reflects the actual time
between time t0 and t measured in years, can be written as:

Discount Rates P(t) = 1− trd(t)

Simple Rates P(t) = (1+ trs(t))−1

Annual Rates P(t) = (1+ r1(t))−t

Semiannual Rates: P(t) =
(
1+

r2(t)
2

)2t

N-annual Rates: P(t) =
(
1+

rN(t)
N

)Nt

Continuous Rates: P(t) = e−trc(t)

Each of these formulae can be inverted. For example: r1(t) = P(t)−1/t − 1.

Day count conventions

When using the discount function to express yield or interest rates, the day count
convention must be taken into consideration. The day count convention is a user-defined,
instrument-specific parameter and is used when valuing that particular instrument.

The alternative day count conventions supported by PRIME are as follows:

☞ 30/360

☞ 30E/360

☞ Act/360

☞ Act/365

☞ NL/365

☞ Act/ActISDA

☞ Act/ActISMA

☞ Act/ActAFB

The meaning of the abbreviations used in the naming of the above conventions is as
follows:
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☞ Act Actual number of calendar days.

☞ NL Actual number of calendar days.

✔ Exception: If the year is a leap year then February is considered to have 28 days
(instead of 29).

☞ 30 Each month is considered to have 30 days.

✔ Exception: If the later date is the last day of February, that month is considered to
have its actual number of days.

✔ Exception: When the later date of the period is the 31st and the first day is not the
30th or the 31st, the month that includes the later date is considered to have its actual
number of days.

☞ 30E Each month has 30 days.

✔ If the later date is the last day of the month of February, that month is considered to
have its actual number of days.

☞ ActISDA Actual number of calendar days. This ISDA method can be used for all
instrument types.

☞ ActISMA Actual number of calendar days. This convention is recommended by ISMA for
euro denominated bonds (also the US treasury convention).

☞ ActAFB Actual number of calendar days. This convention is recommended for French
Government Bonds.

Interest rates are typically expressed for annual periods. The time period measured in
years between two dates, t, is described as the fraction of the number of days between two
dates, td, and the number of days in a year, ty:

t =
td
ty
,

where td and ty are determined according to the specified day count convention.

Forward rates

From the yield curve describing the interest rates that apply between the current date
and a future date, it is possible to determine an implied forward rate, i.e. the rate that “should”
apply between two future dates.

The formula for implied forward rates is based on an arbitrage argument, where the rate
for a specific nominal amount between two future dates can be locked in by borrowing and
lending at the current rates to the future dates.
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The arbitrage condition can be expressed in terms of the discount function as:

P(t0, t2) = P(t0, t1)Q(t0, t1, t2),

where Q(t0, t1, t2) is the implied discount factor at time t0 between time t1 and t2. This
relationship simply states that the present value at t0 of a unit cash flow at time t2 must equal
the present value of a cash flow at time t2, which is first discounted to t1 and then discounted
to t0.

The implied forward discount factor is obtained from this relationship:

Q(t0, t1, t2) =
P(t0, t2)

P(t0, t1)
.

The formula for implied forward rates has the same relationship to the implied forward discount
function as spot rates have to the discount function.

All “floating” cash flows in the system are estimated using implied forward rates.
“Floating” means that the actual interest rate is not fixed at the outset, but determined on
the basis of an index on a particular date before the interest rate period.

Definitions of cash flow instruments

A bill is an instrument where only the nominal amount is paid or received at expiry.
The instrument is traded before expiry at a “discount” of the nominal amount and is a true
zero-coupon instrument.

Bonds are contracts that promise the delivery of known cash flows, at known dates. In
situations when a bond is traded between the end day and the pay day of a coupon, PRIME
handles the cash flows as follows:

☞ For security instruments the cash flow is included in the trade if acquire day is before the
end day of the cash flow.

☞ For non-security instruments the cash flow is included if acquire day is before the pay day
of the cash flow.

An interest rate cap provides protection against the rate of interest on a floating rate
loan going above some level. If the rate of interest goes above this rate the seller of the cap
provides the difference between the interest on the loan and the interest that would be required
if the strike rate applied. There is no valuation logic supported by PRIME core models for caps
or floors with callable or putable features.
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A Certificate of Deposit (CD) is a receipt for a deposit placed with an issuing bank.

A convertible is a bond that incorporates an option. At the maturity date, the principal
can be paid as a predetermined number of stocks of the issuing company, if the bond holder
so desires. Otherwise, the par value is received.

A currency swap has the following components. There are two currencies, say USD ($)
and Euro (c). The swap is initiated at time t0 and involves

➀ an exchange of a principal amount N$ against the principal Mc;

➁ a series of floating interest payments associated with the principals N$ and Mc,
respectively.

Payments are settled at settlement dates, {t1, t2, . . . , tn}. One party will pay the floating

payments L$
ti

N$δi and receive floating payments of size Lcti
Ncδi , where δi is the day-count

adjustment:

δ =
ti − ti−1

D
,

and D denotes the number of calendar days in the year according to the current day-count

convention. The two Libor rates L$
ti

and Lcti
will be determined at set dates {t1, t2, . . . , tn−1}.

An interest rate floor provides protection against the rate of interest on a floating rate
loan going below some level. If the rate of interest goes below this rate the seller of the floor
provides the difference between the interest that would be required if the strike rate applied
and the interest on the loan.

An Forward Rate Agreement (FRA) is a contract that specifies a nominal amount, N,
the dates t1 and t2, and the “price” Ft0. If the Libor rate Lt1 at time t1 is greater than Ft0, than
the purchaser accepts the receipt of (Lt1 − Ft0)δN at time t2. On the other hand, if Lt1 < Ft0
at date t1, the purchaser pays (Ft0 − Lt1)δN.

A Floating Rate Note (FRN) is initiated at time t0 and involves

➀ Buying the FRN at time t0 for a fixed price N;

➁ a series of floating interest payments: Lt0 at time t1, Lt1 at time t2, . . . , Ltn−2 at time
tn−1, Ltn−1 + N at time tn.

A FX-swap is made of a money market deposit and a money market loan in different
currencies written on the same “ticket”.

A Promissory Loan has the property that the coupon is split between the historical
owners of the security.

For example, assume yearly coupons and that Party A owns the security for the first
nine months of the current cash flow period and then Party B buys the security and keeps it at
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least three months. 75% of the coupon will be paid out to Party A and 25% of the coupon will
be paid out to Party B. Obviously, the size of the next coupon depends on the acquire day of
the trade. The coupon cash flows for trades are presented exactly as they will be, taking the
acquire day into account.

Rate indices are used as benchmarks. Foe example, Libor stands for London Interbank
Offered Rate. It is an arithmetic average interest rate that measures the cost of borrowing from
the point of view of a panel of preselected banks in London. Euribor (Brussel), Tibor (Tokyo),
and Hibor (Hong Kong) are examples of other benchmarks.

A Repo/Reverse involves the sale of assets and a simultaneous agreement to
repurchase the same or similar equivalent assets at a future date or on demand for the original
value plus a return on the use of the cash.

☞ A Repo involves lending securities with agreement to repurchase at some time in the
future.

☞ A Reverse involves borrowing securities with an agreement to sell them back at some
time in the future.

A security loan is a contract where a security is temporarily lent to a party. A lending
fee is paid to the party that originally owned the security.
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The lending fee payment is based on the lending rate, the day count method, and the
time period. Coupons paid out during the life of the loan should be transferred to the original
owner of the security.

A swap is a contract where two cash flow sequences are exchanged. The first sequence
of cash flows starts at time t1 and continues periodically at t2, t3, . . . , tk. There are k cash
flows of different sizes denoted by C(st0, xt1), C(st0, xt2), . . . , C(st0, xtk). These cash flows
depend on market or credit risk factors denoted by xti and on st0, a swap spread. By selecting
the value of st0, the initial value of the swap can be made zero.

The second sequence of cash flows, denoted by B(yt0), B(yt1), . . . , B(ytk), depend
potentially on some other risk factors denoted by yti . The swap consists of exchanging the
C(st0, xti ) against B(yti ) at settlement dates ti .

Valuation of cash flow instruments

☞ The appropriate yield curve is found.

☞ Floating cash flows are estimated using implied forward rates.

☞ Contingent cash flows are estimated using an option pricing model.

☞ All cash flows are discounted to the valuation date.

☞ All discounted values are summed.

This gives us the present value.
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Example: bond valuation

Today in November 2, 2004. We are going to calculate the theoretical price of a bond
with the following instrument data:

Quote type: Pct of nominal
Start day: 2004-09-09
End day: 2014-09-09
Fixed Rate: 7.5
Day count: 30E/360
Pay Method: Following
Rolling Period: 1y
Rolling Base Day: 2004-09-09
Fix Period Dates: Yes

In the PRIME Session Manager, choose Trading > Bond . In the View menu of the
Bond application, make items Instrument , Pricing , and Instrument Details active. Input
data, choose File > Save New . The theoretical price is 137.6631.
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Exercises

➀ Calculate the theoretical price of the promissory loan with the following instrument data.

Quote Type: Clean
Nominal: 1 000 000
Start day: 1995-07-24
End day: 2005-07-15
Fixed Rate: 7.5
Day Count: 30E/360
Rolling Period: 1 year
Rolling Base Day: 2005-07-15
Fixed Period Dates: Yes

➁ Calculate the theoretical price of the bill with the following instrument data.

Nominal: 1 000 000
Start: 2004-11-05
End day: 2005-11-05
Day Count: Act/360

➂ Calculate the modified duration and convexity of the bond with the following instrument
data.

Quote Type: Clean
Val Group: Government
Nominal: 2 000 000
Start day: 2004-11-08
End day: 2009-11-09
Fixed Rate: 12
Day Count: Act/ActISMA
YTM: None
Rolling Period: 1 year
Rolling Base Day: 2009-11-08
Pay Offset 0d
Pay Method Following
Notional: Yes

➃ Calculate the present value and vega of the cap with the following instrument data.
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Start day: 2004-11-05
End day: 2007-11-05
Strike: 5
Day Count: Act/360
Val Group: LMM
Float Ref GBP-LIBOR-6M
Pay Cal 1: Target
Rolling: 6m
Rolling Base Day: 2007-11-05
Pay Offset 0d
Pay Method Mod.Following
Exotic type: Chooser
Exercises: 3
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